Please offer " hide the popup permanently" option

Comments

4 comments

  • Avatar
    Brian

    Thank you for the insight! We'll try our best to make the changes you mentioned.

    0
    Comment actions Permalink
  • Avatar
    Raphael

    Thank you for your reply!

    0
    Comment actions Permalink
  • Avatar
    Mindy22050

    The popup is even getting bigger! It's cover the page word that I need to read. Even worse, the "related page" has nothing to "related" to what I was reading. Turn off the popup asap. I've payed for premium, but you guys are change it to the worse place.

     

    0
    Comment actions Permalink
  • Avatar
    Ronnie Mukherjee

    I second this - it is so annoying, please please please allow me to hide this.

    In the meantime I'd be grateful for any workaround e.g. by modifying Chrome's settings somehow?

    0
    Comment actions Permalink

Please sign in to leave a comment.